読者です 読者をやめる 読者になる 読者になる

TMD45'β'LOG!!!

Life is Beta-ful.

NeoBundleUpdate 失敗(たぶん vimproc が何か)

Vim

ひさびさに MacVim アップデートしたのでついでに :NeoBundleUpdate したらエラー。

[neobundle/install] Update started: (2015/06/01 13:02:43)
function neobundle#commands#install..<SNR>27_install..neobundle#installer#sync..neobundle#installer#get_revision_number..neobundle#util#system..vimproc#system..<SNR>85_system の処理中にエラーが検出されました:
行   89:
E605: 例外が捕捉されませんでした: vimproc: vp_pipe_read: '306636386263643933333939656362636465336561613465666430393130373331346339626465650A??0??'
function neobundle#commands#install..<SNR>27_install の処理中にエラーが検出されました:
行   18:
E170: :endwhile がありません
続けるにはENTERを押すかコマンドを入力してください

begin/end 関連の問題は前になんとかしたはず。なんだろ。

call neobundle#begin(expand('~/.vim/bundle/'))
...
call neobundle#end()

vimproc か...?

.vimrc から以下をコメントアウトして :NeoBundleClean, :NeoBundleUpdate (今度は動いた)。 (neocomplcache は多分関係ないんだけど...)

" NeoBundle 'Shougo/vimproc'
" NeoBundle 'Shougo/neocomplcache'
" NeoBundle 'Shougo/neocomplcache-rsense'

vimproc の README 読んで改めて bundle に追加してみた。

NeoBundle 'Shougo/vimproc.vim', {
\ 'build' : {
\     'windows' : 'tools\\update-dll-mingw',
\     'cygwin' : 'make -f make_cygwin.mak',
\     'mac' : 'make -f make_mac.mak',
\     'linux' : 'make',
\     'unix' : 'gmake',
\    },
\ }
NeoBundle 'Shougo/neocomplcache'
NeoBundle 'Shougo/neocomplcache-rsense'

保存して vim 再起動したら、入ってない Bundle をインストールするか聞かれたので (y)es

正常にインストールできた。 もっかい :NeoBundleUpdate してみても問題なくなった。

▲ ページトップへ移動