読者です 読者をやめる 読者になる 読者になる

TMD45'β'LOG!!!

Life is Beta-ful.

さくらのレンタルサーバーにRedmine導入したメモ

さくらのレンタルサーバー Redmine Ruby Ruby on Rails

keyword: さくらのレンタルサーバー, Redmine, Rails

 

プロジェクト管理ツールの Redmine を触る機会があって、興味が湧いたので自分で借りてるさくらのレンタルサーバーでも環境構築してみました。

手順はwikiにまとめたのでそちらをご覧下さい。
Redmineでプロジェクト管理環境構築 - TMD45WIKI!!!

 

で、ハマったのがWikiのほうにも書いたけど、最新バージョンの Redmine 1.1.0 が、ブラウザからアクセスすると

Application error
Rails application failed to start properly"

って表示されて、起動出来なかったこと。

 

コンソールから Redmine の public/dispatch.cgi*1 を直接実行してやると実際に出ているエラーの内容が分かる。

$ ruby public/dispatch.cgi


場合によってはこの方法でエラーの内容が分かって、解決できることもある。
iconvモジュールが足りないとか、DBに接続できないとか。

 

でも今回は↓こんなのが出てた。

./../config/../vendor/rails/railties/lib/rails/gem_dependency.rb:119:Warning: Gem::Dependency#version_requirements is deprecated and will be removed on or after August 2010.  Use #requirement
/home/account/local/redmine/vendor/rails/actionpack/lib/action_controller/cgi_process.rb:22:in `__send__': undefined method `env_table' for nil:NilClass (NoMethodError)
        from /home/account/local/redmine/vendor/rails/actionpack/lib/action_controller/cgi_process.rb:22:in `dispatch_cgi'
        from /home/account/local/redmine/vendor/rails/actionpack/lib/action_controller/dispatcher.rb:101:in `dispatch_cgi'
        from /home/account/local/redmine/vendor/rails/actionpack/lib/action_controller/dispatcher.rb:27:in `dispatch'
        from dispatch.cgi:11


(´・ω・`)?

 

actionpack とかどう見ても Rails の中身だし、ユーザが設定間違えてなんとかなるって部分じゃないよなー
と、思いながらもネットで解決方法を探してみたんだけど、
RedmineとかRailsのフォーラムで「どうしようもないね」的なコメントが付いてる英語の文章しか見つけられなかった。

 

ソースも開いてみたけど、特におかしいと思うところも無かったし(Ruby-erじゃないから分からないけど)。
お手上げやー!と思っていたところに、こんな記事を発見。
さくらレンタルサーバでRedmineをインストールしようとして撃沈したメモ - hellkite 日記と雑記とメモ。
さくらレンタルサーバでRedmineメモ - hellkite 日記と雑記とメモ。

 

なにやらさくらのレンタルサーバーでは Rails 2.2.2 以上が動作しないよう・・・?
Rails の勉強は全くしていないので、詳しい原因はわかりませんが Redmine 0.8.7 まではパッケージに同梱された Rails が 2.1.2 です(参照)。
それ以上だと Rails 2.3.5 になるため、そのままではさくらで動かせないようですね。

 

 

というわけで、おそらく使用する Rails を別に用意して Redmine にパスを通してやれば使えそう。
今回はとりあえず Redmine をいじってみたかっただけなのでこれ以上は検証してませんが。

 

もし Rails 2.2.2 で Redmine 1.x.x 以上を動かす方法があれば教えていただきたいです。
(まぁ Redmine のソースあされば、どっかに使用する Rails のパスとかありそうだけど・・・)



ちなみにいまは Redmine 0.8.7 で導入成功して動かしてます。
が、ほかのサイトでも言われているとおり、動作がひどく遅いので、時間があるときに高速化にも挑戦してみたいと思います〜(●ΦωΦ)

*1:http://accout.sakura.ne.jp/redmine/ とかを実行すると最初に実行されるCGI

▲ ページトップへ移動